Go Back   MMORPG Maker XB Forums > MMORPG Maker XB Development > Bug Reports

Reply
 
Thread Tools Display Modes
  #1  
Old 02-03-2011, 11:08 PM
Nebelstern Nebelstern is offline
Junior Member
 
Join Date: Jan 2011
Posts: 17
Default still problems with loading and compiling

there still seem to be serios trouble with *loading* the makers content, especially map images etc.
also, after trying to build a nice map, it had problems compiling.. it said " Compiling... " but nothing further happened, it got stuck there... needless to say the "Play" option for testing was out of service when that happened...

also, when you try mapping, sometimes the 'drawing' tool seems to get stuck, so that you accidently multiply the selected tile all over the map, moving your mouse, which is very irritating.

sorry for reporting only bad news at present D;
Reply With Quote
  #2  
Old 02-04-2011, 04:11 AM
Administrator Administrator is offline
Administrator
 
Join Date: Jun 2010
Posts: 161
Default

I think we know which specific bugs you're reporting this time.

When you say "map images," are you referring to the Image Object plugin? When we introduced object cloning in the new beta, we only updated the Sprite Object with this feature, but all plugins rendered to a map would need to support cloning in order for the map to play. However, this is an easy fix and we don't have to edit any of the editor code. We'll just have to update all the rendered plugins, and it shouldn't take too long.

Regarding the drawing tool getting "stuck," this is an operating system-level issue. It's caused when you release the mouse while it's over a scrollbar. Our current idea is to remove the scrollbars entirely. The current focus is on the Server Editor so you can create chats, save items and other user data to the server, etc. If the current bug is very irritating, let us know and we'll move it up on our priorities list.
Reply With Quote
  #3  
Old 02-06-2011, 06:29 PM
Nebelstern Nebelstern is offline
Junior Member
 
Join Date: Jan 2011
Posts: 17
Default

okay thanks! hope it's gonna get fixed soon : )
Reply With Quote
  #4  
Old 02-16-2011, 02:24 PM
i9La i9La is offline
Junior Member
 
Join Date: Jan 2011
Posts: 8
Default

When you fix this bug?
When i made new maps,some new maps froze in a test game viewer.
Help please.

Yours sincerely.
Reply With Quote
  #5  
Old 02-17-2011, 07:25 AM
Administrator Administrator is offline
Administrator
 
Join Date: Jun 2010
Posts: 161
Default

Nebelstern,

Your problem should be fixed. It was an issue with our compiler. You can see me playing your game here:

1.png

While the game can be played, you will need to update your map's events. The default player starting position is 0,0. If you leave it at the default, the player will be stuck in the corner blocked by the tree. I set some events to change the player starting location to 250, 120 like so:

2.png

I did NOT save the map because I didn't know which coordinates you wanted so you will need to set the events up yourself.

The editor should now be updated and you can now compile again.

Also, when you said you were stuck on the "loading" screen, I'm assuming you meant the editor loading screen and not the game engine loading screen? Your maps loaded fine for me. Sometimes the HTTP connection might timeout (e.g. on wireless) so if it gets "stuck," try re-loading the map again and it should work. If it doesn't work after several tries, feel free to report a bug.

If this bug is fixed, please let us know so we can close this bug report.

i9La,

I don't believe you're experiencing the same problem as Nebelstern. If the bug still isn't fixed for you, please file a new bug report in a new topic and describe your problem in more detail including what you did to make the bug occur.

For both of you: the Image Object has been re-compiled to work with the latest beta, but I don't think the bug had anything to do with the Image Object.
Reply With Quote
  #6  
Old 02-18-2011, 09:41 AM
i9La i9La is offline
Junior Member
 
Join Date: Jan 2011
Posts: 8
Default

Thank you Admin.
Ok, I`ll make a new bug report in a new topic.

Yours sincerely.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



Powered by vBulletin®
Copyright © 2000 - 2017, Jelsoft Enterprises Ltd. .
Copyright © MMORPG Maker XB. All Rights Reserved.